ILO Notes

From Brandonhutchinson.com

(Difference between revisions)
Jump to: navigation, search
Line 3: Line 3:
=== OpenSSH problems with iLO ssh server ===
=== OpenSSH problems with iLO ssh server ===
-
OpenSSH on my Ubuntu 7.10 system is incompatible with the ssh server on an iLO 1.91 system.
+
The OpenSSH client on my Ubuntu 7.10 system is incompatible with the ssh server on an iLO system with 1.91 firmware.
$ '''ssh -V'''
$ '''ssh -V'''
OpenSSH_4.6p1 Debian-5build1, OpenSSL 0.9.8e 23 Feb 2007
OpenSSH_4.6p1 Debian-5build1, OpenSSL 0.9.8e 23 Feb 2007
-
 
+
$ '''echo "QUIT" | nc ''iLO'' 22'''
$ '''echo "QUIT" | nc ''iLO'' 22'''
-
SSH-2.0-mpSSH_0.0.1
+
SSH-2.0-mpSSH_0.0.1
-
 
+
$ ssh admin@''iLO''
$ ssh admin@''iLO''
admin@''iLO'''s password:
admin@''iLO'''s password:

Revision as of 19:11, 1 November 2007

In the following notes, "iLO" refers to iLO and iLO 2 unless otherwise noted.

OpenSSH problems with iLO ssh server

The OpenSSH client on my Ubuntu 7.10 system is incompatible with the ssh server on an iLO system with 1.91 firmware.

$ ssh -V
OpenSSH_4.6p1 Debian-5build1, OpenSSL 0.9.8e 23 Feb 2007

$ echo "QUIT" | nc iLO 22
SSH-2.0-mpSSH_0.0.1

$ ssh admin@iLO
admin@iLO's password: 
dispatch_protocol_error: type 100 seq 9
dispatch_protocol_error: type 100 seq 10
buffer_get_ret: trying to get more bytes 4 than in buffer 0
buffer_get_int: buffer error

As a workaround, PuTTY 0.60-1's ssh client works with the iLO ssh server.

Upgrading Firmware

To upgrade iLO firmware through the iLO HTTPS interface, download the Online ROM Flash Component for Windows, Extract the files, and Send firmware image of the appropriate firmware file (e.g., ilo191.bin). Note that wine for UNIX systems works with the self-extracting .exe file.

Personal tools